Set the integer value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
A family parameter of the current type.
- value
- Type: System Int32
The new value for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid. |