Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- connector1
- Type: Autodesk.Revit.DB Connector
The first connector to be connected to the cross.
- connector2
- Type: Autodesk.Revit.DB Connector
The second connector to be connected to the cross.
- connector3
- Type: Autodesk.Revit.DB Connector
The third connector to be connected to the cross.
- connector4
- Type: Autodesk.Revit.DB Connector
The fourth connector to be connected to the cross.
Return Value
If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors' end if necessary, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument connector1, connector2, connector3, or connector4 is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the connectors cannot be used for cross creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when cross fitting cannot be created. |