Creates a slab edge along a reference array.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- SlabEdgeType
- Type: Autodesk.Revit.DB SlabEdgeType
The type of the slab edge to create
- references
- Type: Autodesk.Revit.DB ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.
Return Value
If successful a new slab edge object within the project, otherwise a null reference ( Nothing in Visual Basic) .Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the slab edge type does not exist in the given document. |