Exports a view specified in the export options to the STL format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2021.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: System String
Output folder into which the file will be exported. The folder must exist.
- name
- Type: System String
Indicates the name of the STL file to export. If it doesn't end with ".stl", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
- options
- Type: Autodesk.Revit.DB STLExportOptions
Various options applicable to the STL format.
Return Value
True if successful, otherwise False.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options are not valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
Autodesk.Revit.Exceptions InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
Autodesk.Revit.Exceptions InvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.Exceptions OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit. |