This class defines an enumerative type used to specify the state of a BRepBuilder object.
This enumerative type corresponds to the possible states of a BRepBuilder object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
InvalidState | BRepBuilder is in an invalid state. No further productive use is possible. |
AcceptingData | BRepBuilder is accumulating data. New b-rep components such as edges or faces may be added. |
Completed | Finish() successfully created a valid Geometry object. No new data may be added.The built object may be retrieved via GetResult(). |