Transformed Property


Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Mesh this[
	Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
	transform As Transform _
) As Mesh
	Get
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
	Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DBTransform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the handle of the specified transformation is a null reference (Nothing in Visual Basic).

See Also