Sets the Layout Rule property of rebar set to FixedNumber.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- numberOfBarPositions
- Type: SystemInt32
The number of bar positions in rebar set
- arrayLength
- Type: SystemDouble
The distribution length of rebar set
- barsOnNormalSide
- Type: SystemBoolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar
- Type: SystemBoolean
Identifies if the first bar in rebar set is shown
- includeLastBar
- Type: SystemBoolean
Identifies if the last bar in rebar set is shown
Remarks
When changing the layout rule to FixedNumber, you must also simultaneously set NumberOfBarPositions, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- the set length arrayLength isn't acceptable. |
Autodesk.Revit.ExceptionsInapplicableDataException | This RebarShapeDrivenAccessor is an instance of a spiral or multiplanar shape. |
Autodesk.Revit.ExceptionsInvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |