Gets the area of the material with the given id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- materialId
- Type: Autodesk.Revit.DBElementId
The material id returned from GetMaterialIds(Boolean).
- usePaintMaterial
- Type: SystemBoolean
If true, this material id was returned as a paint material from GetMaterialIds(Boolean) and the area returned should be calculated from paint applied to the element. If false, this material id was returned as a non-paint element material from GetMaterialIds(Boolean) and the area is calculated from the element geometry and layers.
Return Value
The area of the material for this element. Returns 0.0 if the material id is not a part of this element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | materialId is not a valid Element identifier. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This Element element does not support paint material assignment. |