AlignedFreeFormSetOrientationOptions Property


Orientation options for an Aligned Free Form Rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public AlignedFreeFormSetOrientationOptions AlignedFreeFormSetOrientationOptions { get; set; }
Visual Basic
Public Property AlignedFreeFormSetOrientationOptions As AlignedFreeFormSetOrientationOptions
	Get
	Set
Visual C++
public:
property AlignedFreeFormSetOrientationOptions AlignedFreeFormSetOrientationOptions {
	AlignedFreeFormSetOrientationOptions get ();
	void set (AlignedFreeFormSetOrientationOptions value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference. -or- This RebarFreeFormAccessor Rebar is not created with the Aligned Free Form rebar server.

See Also