LinkedViewId Property


The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView , then there must be a valid LinkedViewId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public ElementId LinkedViewId { get; set; }
Visual Basic
Public Property LinkedViewId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ LinkedViewId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also