Converts a value from one unit to another, such as square feet to square meters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- value
- Type: SystemDouble
The value to convert.
- currentUnitTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the current unit.
- desiredUnitTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the desired unit.
Return Value
The converted value.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for value is not finite -or- currentUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- desiredUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | currentUnitTypeId and desiredUnitTypeId have different dimensions. |