Deletes points from a Topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- points
- Type: System.Collections.GenericIListXYZ
A collection of points to be deleted.
Remarks
Points will be deleted if they matched in XY. This function ignores input points that do not exist, unless all of the input points do not exist, which will result in an exception. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which shoule be in an active TopographyEditScope.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | There are no points in the input points set. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This element is not a TopographySurface. -or- The topography surface is not editable. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface. -or- The points of this topography surface are not editable. -or- None of the input points exists in the current TopographySurface. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document containing this TopographySurface has no open transaction. |