SetFailuresPreprocessor Method


Sets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
	IFailuresPreprocessor preprocessor
)
Visual Basic
Public Function SetFailuresPreprocessor ( _
	preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
	IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DBIFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.

Return Value

This FailureHandlingOptions object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also