SetRestrictPalette Method


Restrict the placement of parts to only use parts associated to the passed in fabrication palette identifier.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void SetRestrictPalette(
	bool restrictPalette
)
Visual Basic
Public Sub SetRestrictPalette ( _
	restrictPalette As Boolean _
)
Visual C++
public:
void SetRestrictPalette(
	bool restrictPalette
)

Parameters

restrictPalette
Type: SystemBoolean

See Also