Updates the externally tagged geometry object in the DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externallyTaggedGeometry
- Type: Autodesk.Revit.DBExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShapeType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShapeType. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |