CurrentTheme Property


The current overall theme which impacts the Revit frame and canvas.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static UITheme CurrentTheme { get; set; }
Visual Basic
Public Shared Property CurrentTheme As UITheme
	Get
	Set
Visual C++
public:
static property UITheme CurrentTheme {
	UITheme get ();
	void set (UITheme value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also