Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- name
- Type: SystemString
The name.
- target
- Type: Autodesk.Revit.DBFillPatternTarget
The fill pattern target.
- orientation
- Type: Autodesk.Revit.DBFillPatternHostOrientation
The fill pattern orientation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |