Sets the value of the bent fabric sheet segment(like A, B, C, D etc.)
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segmentParameterId
- Type: Autodesk.Revit.DBElementId
The segment ID of the bent fabric sheet.
- value
- Type: SystemDouble
The length value to set
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for value is not a number -or- |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for value must be between 0 and 30000 feet. |