GetAlignmentStationLabels Method (Alignment)


Returns all alignment station labels placed on the given alignment.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021.1

Syntax

C#
public static ICollection<AlignmentStationLabel> GetAlignmentStationLabels(
	Alignment alignment
)
Visual Basic
Public Shared Function GetAlignmentStationLabels ( _
	alignment As Alignment _
) As ICollection(Of AlignmentStationLabel)
Visual C++
public:
static ICollection<AlignmentStationLabel^>^ GetAlignmentStationLabels(
	Alignment^ alignment
)

Parameters

alignment
Type: Autodesk.Revit.DB.InfrastructureAlignment
The alignment for which the labels are returned.

Remarks

The resulting collection may contain both "individual" labels (created via Create(Alignment, View, AlignmentStationLabelOptions)) and "labels in set" (created via CreateSet(Alignment, View, AlignmentStationLabelSetOptions)). These labels have categories respectively OST_Alignments and OST_AlignmentStationLabelSets.

See Also