AssemblyName Property


The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
	Get
	Set
Visual C++
public:
property String^ AssemblyName {
	String^ get ();
	void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when setting the value to a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when setting the value to an empty string.
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also