RemoveExternallyTaggedGeometry Method


Removes the externally tagged geometry object by its external ID from this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void RemoveExternallyTaggedGeometry(
	ExternalGeometryId externalId
)
Visual Basic
Public Sub RemoveExternallyTaggedGeometry ( _
	externalId As ExternalGeometryId _
)
Visual C++
public:
void RemoveExternallyTaggedGeometry(
	ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DBExternalGeometryId
The external ID of the externally tagged geometry that should be removed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The externally tagged geometry with the input externalId is not present in this DirectShapeType.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also