DuplicateBaluster Method


Duplicates the baluster pointed by given index in the main baluster pattern.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019

Syntax

C#
public BalusterInfo DuplicateBaluster(
	int index
)
Visual Basic
Public Function DuplicateBaluster ( _
	index As Integer _
) As BalusterInfo
Visual C++
public:
BalusterInfo^ DuplicateBaluster(
	int index
)

Parameters

index
Type: SystemInt32
Baluster index.

Return Value

The duplicated baluster.

Remarks

The new baluster will be inserted just after the source baluster.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The index index is out of range.

See Also