Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Remarks
For synchronizing with central operation, there are 4 steps. 1) Save to local (before save to central) - Serializes the streams from memory to local disk cache; [!:Autodesk::Revit::DB::Events::DocumentSaveToLocalProgressChangedEventArgs] 2) Reload latest - Downloads the streams from central model on server and merge them into local memory; [!:Autodesk::Revit::DB::Events::DocumentReloadLatestProgressChangedEventArgs] 3) Save to central - Uploads merged streams from local memory to server central model; [!:Autodesk::Revit::DB::Events::DocumentSaveToCentralProgressChangedEventArgs] 4) Save to local (after save to central) - Serializes the merged streams from memory to local disk cache; [!:Autodesk::Revit::DB::Events::DocumentSaveToLocalProgressChangedEventArgs]
For document open operation, just download the model from server and then open it; [!:Autodesk::Revit::DB::Events::CreateRelatedFileProgressChangedEventArgs]
It is NOT recommended to deal with time-consuming work when handling WorksharedOperationProgressChanged event, otherwise it would increase synchronizing with central or model open time.
Inheritance Hierarchy
SystemEventArgs
Autodesk.Revit.DB.EventsRevitAPIEventArgs
Autodesk.Revit.DB.EventsRevitAPISingleEventArgs
Autodesk.Revit.DB.EventsWorksharedOperationProgressChangedEventArgs
Autodesk.Revit.DB.EventsDataTransferProgressChangedEventArgs
Autodesk.Revit.DB.EventsDocumentSaveToLocalProgressChangedEventArgs