NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)


Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Dimension NewArcLengthDimension(
	View view,
	Arc arc,
	Reference arcRef,
	Reference firstRef,
	Reference secondRef,
	DimensionType dimensionType
)
Visual Basic
Public Function NewArcLengthDimension ( _
	view As View, _
	arc As Arc, _
	arcRef As Reference, _
	firstRef As Reference, _
	secondRef As Reference, _
	dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
	View^ view, 
	Arc^ arc, 
	Reference^ arcRef, 
	Reference^ firstRef, 
	Reference^ secondRef, 
	DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DBView
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DBArc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DBReference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DBReference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DBReference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.DBDimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when any input argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the creation failed.

See Also