CurtainSystemType Property


get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic
Public Property CurtainSystemType As CurtainSystemType
	Get
	Set
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
	CurtainSystemType^ get ();
	void set (CurtainSystemType^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the specified parameter curtainSystemType is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also