Roughness Property


The roughness value for given material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
	Get
	Set
Visual C++
public:
property double Roughness {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsDisabledDisciplineException When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also