Creates a new instance of a piping system and adds it to the document.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADocument
- Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
- typeId
- Type: Autodesk.Revit.DBElementId
The identifier of this piping system element's type.
Return Value
The newly created piping system element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The typeId is not an element id for a valid piping system type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |