Returns true if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
Returns true if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.Remarks
Throw exception if it's used on start/end handle to start/end handle constraint, and on constraints involving bar/hook bend handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarConstraint constrain two Rebar ends. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |