ShadeDepth Property


Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic
Public Property ShadeDepth As Double
	Get
	Set
Visual C++
public:
property double ShadeDepth {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The shade depth is less than zero.

See Also