IsWallBaseRectangular Method


Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static bool IsWallBaseRectangular(
	Wall wall,
	Curve curve
)
Visual Basic
Public Shared Function IsWallBaseRectangular ( _
	wall As Wall, _
	curve As Curve _
) As Boolean
Visual C++
public:
static bool IsWallBaseRectangular(
	Wall^ wall, 
	Curve^ curve
)

Parameters

wall
Type: Autodesk.Revit.DBWall
The wall.
curve
Type: Autodesk.Revit.DBCurve
The wall's base curve.

Return Value

True if the wall's base can be represented by a direct thickening of the wall's base curve. False if the wall's base shape is affected by other geometry, and thus cannot be represented by a direct thickening of the wall's base cure.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also