Returns 0 or 1 to indicate which end hook on the other Rebar Element to which this RebarConstraint is attached. The RebarConstraint must be of RebarConstraintType 'ToOtherRebar,' and the TargetRebarConstraintType must be 'HookBend.' Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
0 means start of the bar, and 1 indicates end of the bar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is not 'HookBend' -or- Constrained rebar is a free form rebar element. |