Profile Property


Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic
Public Property Profile As FamilySymbol
	Get
	Set
Visual C++
public:
property FamilySymbol^ Profile {
	FamilySymbol^ get ();
	void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory.OST_ProfileFamilies.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.

See Also