CreateMeshByExtrusion Method


Builds a mesh by extruding curve loop(s) along extrusion distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static MeshFromGeometryOperationResult CreateMeshByExtrusion(
	IList<CurveLoop> profileLoops,
	XYZ extrusionDirection,
	double extrusionDistance,
	ElementId materialId
)
Visual Basic
Public Shared Function CreateMeshByExtrusion ( _
	profileLoops As IList(Of CurveLoop), _
	extrusionDirection As XYZ, _
	extrusionDistance As Double, _
	materialId As ElementId _
) As MeshFromGeometryOperationResult
Visual C++
public:
static MeshFromGeometryOperationResult^ CreateMeshByExtrusion(
	IList<CurveLoop^>^ profileLoops, 
	XYZ^ extrusionDirection, 
	double extrusionDistance, 
	ElementId^ materialId
)

Parameters

profileLoops
Type: System.Collections.GenericIListCurveLoop
The profile loops to be extruded. The loops will not be modified.
extrusionDirection
Type: Autodesk.Revit.DBXYZ
Direction of extrusion. The length of this vector is ignored.
extrusionDistance
Type: SystemDouble
The positive distance by which the loops are extruded in the direction of the input extrusionDir.
materialId
Type: Autodesk.Revit.DBElementId
Material which should be used by a constructed mesh.

Return Value

Returns a mesh, which was constructed, and some additional information.

Remarks

This function supports creation of a mesh given a collection of continuous curve loops, which are processed independently from each other. Loops with gaps or with curves with wrong flips will be split before processing.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input value cannot be used as thickness for an extrusion, or blend, or wall layer, or similar geometric construct.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException extrusionDirection has zero length.

See Also