Sets a column's category and parameter Id
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nCol
- Type: SystemInt32
- paramId
- Type: Autodesk.Revit.DBElementId
- categoryId
- Type: Autodesk.Revit.DBElementId
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given column number nCol is invalid. -or- The paramId or categoryId is not acceptable. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This operation is forbidden for cells in standard schedule body sections. |