ShowDialog Method


Shows dialog on managing IFCEntityTreeUI.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
bool ShowDialog(
	IFCExternalServiceUIData data
)
Visual Basic
Function ShowDialog ( _
	data As IFCExternalServiceUIData _
) As Boolean
Visual C++
bool ShowDialog(
	IFCExternalServiceUIData^ data
)

Parameters

data
Type: Autodesk.Revit.UIIFCExternalServiceUIData
The data on initializing the dialog as well as getting the result.

Return Value

Whether or not the dialog launches successfully

See Also