MaterialId Property


The material id associated with the non-continuous rail, or invalidElementId if none.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2019

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ MaterialId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The materialId is not a valid value to be used as a non-continuous rail material Id.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was null

See Also