SetMaterialId Method


Sets a material element for a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetMaterialId(
	int layerIdx,
	ElementId materialId
)
Visual Basic
Public Sub SetMaterialId ( _
	layerIdx As Integer, _
	materialId As ElementId _
)
Visual C++
public:
void SetMaterialId(
	int layerIdx, 
	ElementId^ materialId
)

Parameters

layerIdx
Type: SystemInt32
Index of a layer in the CompoundStructure.
materialId
Type: Autodesk.Revit.DBElementId
The ElementId of a Material element.

Remarks

It is not verified that materialId corresponds to a valid Material element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The layer index is out of range.

See Also