OriginatingElementName Property


The name for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public string OriginatingElementName { get; }
Visual Basic
Public ReadOnly Property OriginatingElementName As String
	Get
Visual C++
public:
property String^ OriginatingElementName {
	String^ get ();
}

Remarks

Surface elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name) : (Family Type)

Sample: Basic Wall : Cast Concrete Wall 12"

See Also