HostedSweepType Class


An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class HostedSweepType : HostObjAttributes
Visual Basic
Public Class HostedSweepType _
	Inherits HostObjAttributes
Visual C++
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBHostObjAttributes
        Autodesk.Revit.DBHostedSweepType
          Autodesk.Revit.DB.ArchitectureFasciaType
          Autodesk.Revit.DB.ArchitectureGutterType
          Autodesk.Revit.DBSlabEdgeType

See Also