SetHookOrientationAngle Method


Set the hook orientation angle at end. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public void SetHookOrientationAngle(
	int end,
	double angle
)
Visual Basic
Public Sub SetHookOrientationAngle ( _
	end As Integer, _
	angle As Double _
)
Visual C++
public:
void SetHookOrientationAngle(
	int end, 
	double angle
)

Parameters

end
Type: SystemInt32
The end of bar. Should be 0 for start or 1 for end.
angle
Type: SystemDouble
The hook orientation angle at end.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException Invalid end.
Autodesk.Revit.ExceptionsInvalidOperationException This RebarFreeFormAccessor Rebar is constrained.

See Also