SetElementIds Method


Replaces the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetElementIds(
	ICollection<ElementId> ids
)
Visual Basic
Public Sub SetElementIds ( _
	ids As ICollection(Of ElementId) _
)
Visual C++
public:
void SetElementIds(
	ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.GenericICollectionElementId
The new set of ElementIds.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also