GetNearestLevelId Method (Document, Double)


Returns id of the Level which is closest to the specified elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static ElementId GetNearestLevelId(
	Document document,
	double elevation
)
Visual Basic
Public Shared Function GetNearestLevelId ( _
	document As Document, _
	elevation As Double _
) As ElementId
Visual C++
public:
static ElementId^ GetNearestLevelId(
	Document^ document, 
	double elevation
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
elevation
Type: SystemDouble
Target Elevation.

Remarks

The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also