CanUseHookType Method


Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool CanUseHookType(
	ElementId proposedHookId
)
Visual Basic
Public Function CanUseHookType ( _
	proposedHookId As ElementId _
) As Boolean
Visual C++
public:
bool CanUseHookType(
	ElementId^ proposedHookId
)

Parameters

proposedHookId
Type: Autodesk.Revit.DBElementId
The Id of the RebarHookType

Return Value

Returns true if the id is of a valid RebarHookType for the Rebar element.

Remarks

Also, checks that the Style of the Hook matches that of the Rebar's RebarShape

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also