Writes a PartAtom XML from the contents of a family file.
Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyFilePath
- Type: SystemString
The family file to be processed.
- xmlFilePath
- Type: SystemString
The xml file to be saved.
Remarks
If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom. To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | If 'familyFilePath' or 'xmlFilePath' is a null reference (Nothing in Visual Basic) or an empty string or if the family file doesn't exist on disk. |