Exports the current view or a selection of views in DWF format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: SystemString
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: SystemString
Either the name of a single file or a prefix for a set of files. If a null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
- views
- Type: Autodesk.Revit.DBViewSet
Selection of views to be exported.
- options
- Type: Autodesk.Revit.DBDWFExportOptions
Various options applicable to the DWF format. If a null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
Function returns true only if all specified views are exported successfully. Returns False if exporting of any view fails, even if some views might have been exported successfully.Remarks
All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
Examples

public bool ExportViewToDWF(Document document, View view, string pathname)
{
DWFExportOptions dwfOptions = new DWFExportOptions();
// export with crop box and area and room geometry
dwfOptions.CropBoxVisible = true;
dwfOptions.ExportingAreas = true;
dwfOptions.ExportTexture = false;
ViewSet views = new ViewSet();
views.Insert(view);
return (document.Export(Path.GetDirectoryName(pathname),
Path.GetFileNameWithoutExtension(pathname), views, dwfOptions));
}

Public Function ExportViewToDWF(document As Document, view As View, pathname As String) As Boolean
Dim dwfOptions As New DWFExportOptions()
' export with crop box and area and room geometry
dwfOptions.CropBoxVisible = True
dwfOptions.ExportingAreas = True
dwfOptions.ExportTexture = False
Dim views As New ViewSet()
views.Insert(view)
Return (document.Export(Path.GetDirectoryName(pathname), Path.GetFileNameWithoutExtension(pathname), views, dwfOptions))
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input views is a null reference (Nothing in Visual Basic) |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input views is an empty ViewSet. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the current document is not modifiable. |