GetValidSymbols Method


Gets the identifiers of all valid symbols for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public IList<ForgeTypeId> GetValidSymbols()
Visual Basic
Public Function GetValidSymbols As IList(Of ForgeTypeId)
Visual C++
public:
IList<ForgeTypeId^>^ GetValidSymbols()

Return Value

Identifiers of the valid symbols.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException UseDefault is true in this FormatOptions.

See Also