Create Method


Creates a new instance of a bending detail.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static Element Create(
	Document document,
	ElementId viewId,
	ElementId reinforcementElementId,
	int reinforcementElementSubelementKey,
	RebarBendingDetailType bendingDetailType,
	XYZ position,
	double rotation
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	viewId As ElementId, _
	reinforcementElementId As ElementId, _
	reinforcementElementSubelementKey As Integer, _
	bendingDetailType As RebarBendingDetailType, _
	position As XYZ, _
	rotation As Double _
) As Element
Visual C++
public:
static Element^ Create(
	Document^ document, 
	ElementId^ viewId, 
	ElementId^ reinforcementElementId, 
	int reinforcementElementSubelementKey, 
	RebarBendingDetailType^ bendingDetailType, 
	XYZ^ position, 
	double rotation
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Document to which the new element should be added.
viewId
Type: Autodesk.Revit.DBElementId
The id of the view in which the new element should be added.
reinforcementElementId
Type: Autodesk.Revit.DBElementId
The reinforcement element Id that this object will represent.
reinforcementElementSubelementKey
Type: SystemInt32
The index of the sub-element from the reinforcement element that this object will represent.
bendingDetailType
Type: Autodesk.Revit.DB.StructureRebarBendingDetailType
The bending details type used with the resulting object.
position
Type: Autodesk.Revit.DBXYZ
The initial position in the view where this object will be created.
rotation
Type: SystemDouble
The initial rotation in the view for this element.

Return Value

Returns an instance of a bending detail.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also