AddWireSize Method


Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public WireSize AddWireSize(
	string size,
	long ampacity,
	double diameter
)
Visual Basic
Public Function AddWireSize ( _
	size As String, _
	ampacity As Long, _
	diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize(
	String^ size, 
	long long ampacity, 
	double diameter
)

Parameters

size
Type: SystemString
Size of wire size.
ampacity
Type: SystemInt64
Ampacity of wire size to be added.
diameter
Type: SystemDouble
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also