CreateBeginsWithRule Method (ElementId, String)


Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static FilterRule CreateBeginsWithRule(
	ElementId parameter,
	string value
)
Visual Basic
Public Shared Function CreateBeginsWithRule ( _
	parameter As ElementId, _
	value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateBeginsWithRule(
	ElementId^ parameter, 
	String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DBElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: SystemString
The user-supplied string value for which values from the document will be searched.

Return Value

Created filter rule object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also