Name Property


The name of the non-continuous rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
	Get
	Set
Visual C++
public:
property String^ Name {
	String^ get ();
	void set (String^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: name is an empty string or contains only whitespace. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: The name name is not valid for the non-continuous rail.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also